본문 바로가기
카테고리 없음

yum 으로 아파치 웹서버 최신 버전 업데이트 하기

by 초짜 주인장 수표 2019. 1. 1.

리눅스 CentOS 7 기준,
yum으로 아파치 웹서버를 설치하면 최신버전이 설치되지 않는다. (2.4.6 버전 설치)

최신버전은 드러나지 않은 버그들이 존재할 수 있기에 그런것이지만
yum으로 설치한 아파치 버전도 보안 취약점이 존재하였기에
최신 버전으로 업데이트 하기로 하였다.


참고로 현재(2018년 9월) 아파치 웹서버의 최신 버전은 2.4.34(relased 2018-07-16) 이다.

# yum info httpd    --> 현재 설치된 httpd 버전 확인


기본 yum 저장소에는 최신 버전의 아파치 웹서버를 찾을 수 없기 때문에

CodeIT 에서 만든 커스텀 저장소(repo)를 사용해야 한다.


이를 사용하기 위해 EPEL을 활성화 해야 한다.


# yum install -y epel-release


설치 후 CodeIT 저장소를 활성화 한다.


cd /etc/yum.repos.d && wget https://repo.codeit.guru/codeit.el`rpm -q --qf "%{VERSION}" $(rpm -q --whatprovides redhat-release)`.repo



활성화 후


# yum info httpd    -->  최신 버전의 아파치(2.4.34) 다운로드가 가능함을 확인


 
활성화 후

이제 최신버전의 아파치 웹서버를 설치해주면 된다.



# yum install httpd

# systemctl enable httpd    --> 아파치웹서버 서비스 등록

# systemctl start httpd    --> 아파치웹서버 시작


2020/01/31 - [C] - [C++] std::string 앞 뒤에 개행문자 제거

2020/01/31 - [C] - [C++] using namespace std; 를 사용하면 안되는 이유

2020/01/27 - [C] - Native C로 리듬게임 만들기 #1

2018/12/24 - [분류 전체보기] - Json 기본 문법

2019/01/01 - [분류 전체보기] - yum 으로 아파치 웹서버 최신 버전 업데이트 하기

2019/01/04 - [분류 전체보기] - PHP 필수 설치 모듈 추천

2019/01/05 - [분류 전체보기] - PHP에서 리눅스 명령어 실행하기


댓글0